Unable to create OpenGL 4.0 context (flags m, profile n)

If you’re getting the message Unable to create OpenGL 4.0 context (flags m, profile n) when creating your context (where m and n are numbers) your hardware does not support OpenGL 4.0.

Sadly, this is not something you can fix without upgrading your hardware. As mentioned in the Preface, the minimum graphics hardware you need for an OpenGL 4.0 context is:

  • If you own an NVIDIA GPU, it must at least be in the Fermi family of products, starting with the GeForce GTX 400 series.
  • If you own an AMD/ATI GPU, it must at least be in the Radeon HD 5000 series.

It is possible to run many of the samples using OpenGL 3.3 by using the code files found in the “OpenGL 3.3″ directories of each chapters’ source code listings. However, OpenGL 4.0+ core features will not work in OpenGL 3.3.

This entry was posted in Information and tagged , . Bookmark the permalink.
  • Przemysław Lib

    Well, you need up to date graphic drivers, for OpenGL 4.0/4.1. That should not be a problem, since you would need really old ones to not have OpenGL 4.x support but still….

  • http://thereactivearts.com Quazi Irfan

    Hey, Eddy, any new chapter in the horizon?

    • Przemysław Lib

      There should be a button on this site with white text “Want more!”, on big red circle!

  • Pingback: OpenGL 4.0 教程 | AirCapsule

  • Pablo Aizpiri

    You’re post says “Sadly, this is not something you can fix without upgrading your hardware.” you should change it to say *can’t* . :)